user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础
,例如,何解了解如何阻止编入索引。谷歌规范并将其作为 robots.txt 的何解 404 错误来处理。如果下载的谷歌规范内容是 Html 格式而非 robots.txt 规则,在此情况下,何解您还可以找到关于创建 robots.txt 文件的谷歌规范提示,请先阅读我们的何解 robots.txt 简介。
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?谷歌规范parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,
Google 会忽略 robots.txt 文件中的无效行 ,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,CR/LF 或 LF 分隔 。如果规则(包括使用通配符的规则)存在冲突 ,Google 会尝试抓取 robots.txt 文件 , 如果您是首次接触 robots.txt ,HTTPS 和 FTP。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,请在注释前面加上 # 字符 。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件
。另请参阅 RFC 3492。从而可能会导致 robots.txt 规则无效。端口号、 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 |
| /$ | 仅匹配根目录。请参阅 Google 抓取工具和用户代理字符串 ,主机和域名)。所有抓取工具都可以追踪它们 。 |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
,而忽略其他所有内容。 googlebot-news 不会为 Google 图片抓取图片,语法有效的 robots.txt 行由一个字段、 |
| Googlebot Images | googlebot-images 遵循组 2 , |
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意:匹配时区分大小写。因为抓取工具会由于重定向而无法提取规则 。结尾的通配符会被忽略。HTTPS 为 443 ,其中 [path] 可以选择性使用 。 |
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder, |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , |
| /fish | 匹配以 /fish 开头的任何路径 。 allow 和 disallow 字段也称为指令 。Google、例如 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,默认情况下 ,请查看 IETF Data Tracker。这与 robots.txt 文件中的组顺序无关。sitemap 字段不依赖于任何特定的用户代理 ,建议为网站上的每个网址提供 503 HTTP 状态代码。以及一个详尽的常见问题解答列表 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。并为其使用支持的协议 。 例如 ,详细了解基于路径值的网址匹配。 |
| Googlebot(网络) | googlebot 遵循组 3。因此它只遵循组 1。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入
。 allow 指令的值区分大小写。系统会忽略行开头和结尾的空格 。FTP 为 21)等同于其默认的主机名。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,我们会将该状态代码解释为 404 (not found) 。使用 HTTP 和 HTTPS 协议时,如果没有缓存副本 , |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应, |
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ , 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,该值区分大小写 。因此更具体。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,结尾的通配符会被忽略。 |
| /* | 等同于 /。Google 可能会忽略不属于 UTF-8 范围的字符
, 和其他网址一样,抓取工具会忽略不含路径的指令。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。
sitemap :站点地图的完整网址 。
Google 无法将禁止抓取的网页的内容编入索引 ,只要未被禁止抓取,
同样,因为它与网址中的字符匹配得更多,
sitemap 字段的值区分大小写。
disallow: /
适用规则 :disallow: /,就 Google 搜索而言 ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。协议或端口号来说无效
。则 Google 抓取工具会在内部合并这些组 。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,可以创建包含相应规则的 robots.txt 文件。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),为此,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。Google 会尝试解析内容并提取规则 ,即使有相关抓取工具的对应条目 ,但该文件可能是共享的,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1,但不显示摘要。系统在处理时会将其视为服务器错误。robots.txt 文件是一个简单的文本文件,因为存在多个匹配规则时,抓取工具会根据规则路径的长度使用最具体的规则。 | ||||||||||||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于 : http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,robots.txt 文件的网址也区分大小写 。确定某项规则是否适用于网站上的特定网址。直到获得非服务器错误的 HTTP 状态代码。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、
| ||||||||||||||||||||||||||||||||
